Latest0.4.0
Homepagehttps://github.com/polyv/PolyvSocketAPI
LicenseMIT
Platformsios 8.0, requires ARC
DependenciesSocket.IO-Client-Swift
Authors

当前版本:

  • PolyvSocketAPI ~ 0.3.0(包含依赖库)

依赖库版本:

  • Socket.IO-Client-Swift ~ 12.1.3
  • Starscream ~ 2.1.1

Podfile 中添加

platform :ios, "8.0"

use_frameworks!

target 'YourApp' do

    pod 'PolyvSocketAPI', '~> 0.3.0'
end

# 以下设置 Pods 子 Target 的 Swift 版本为 4.0
post_install do |installer|
    installer.pods_project.targets.each do |target|
        target.build_configurations.each do |configuration|
            configuration.build_settings['SWIFT_VERSION'] = "4.0"
        end
    end
end

历史版本

v0.3.0

#import <PLVSocketAPI/PLVSocketAPI.h>

依赖库版本:

  • Socket.IO-Client-Swift ~ 12.1.3
  • Starscream ~ 2.1.1

直接下载:0.3.0

CocoaPods: pod 'PolyvSocketAPI', '~> 0.3.0'

v0.2.1

#import <PLVChatManager/PLVChatManager.h>

依赖库版本:

  • Socket.IO-Client-Swift ~ 12.0.0
  • StarscreamSocketIO ~ 8.0.7

直接下载:0.2.1

CocoaPods: pod 'PolyvLiveAPI', '~> 0.2.1'

Latest podspec

{
    "name": "PolyvSocketAPI",
    "version": "0.4.0",
    "summary": "Polyv iOS u76f4u64adu89c2u770bu3001u63a8u6d41u3001u804au5929u5ba4u76f8u5173u63a5u53e3.",
    "homepage": "https://github.com/polyv/PolyvSocketAPI",
    "license": {
        "type": "MIT"
    },
    "authors": {
        "ftao": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/polyv/PolyvSocketAPI.git",
        "tag": "0.4.0"
    },
    "vendored_frameworks": "frameworks/PLVSocketAPI.framework",
    "requires_arc": true,
    "dependencies": {
        "Socket.IO-Client-Swift": [
            "~>13.2.0"
        ]
    }
}

Pin It on Pinterest

Share This