Latest 0.0.1
Homepage https://github.com/pokt-network/pocket-swift
License MIT MIT License

Copyright (c) 2019 Pocket Network

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the “Software”), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

Platforms ios 11.0
Authors , ,

PocketSwift

Official Swift client to use with the Pocket Network

Overview

PocketSwift wraps all of the tools a developer will need to begin interacting with a network. PocketSwift contains 4 packages:

  • PocketEth: A library that allows your DApp to communicate to the Ethereum network.
  • PocketAion: A library that allows your DApp to communicate to the AION network.
  • PocketCore: An implementation of the Pocket protocol that you can use to create your own plugin to interact with a blockchain of your choosing.
  • PocketSwift: Contains the 3 beforementioned packages.

Before you can start using the library, you have to acquire a Developer ID by registering for MVP. To learn how to register please click here.

Requirements

You should have at least have a basic knowledge of blockchain technology and know your way around Swift. You will also need to install the Cocoapods tool.

Installation

The PocketSwift packages are managed using Cocoapods, see below how to install each individual package.

We will be using Cocoapods, to download the pod files into your project. Inside your pod file, enter:
For the full package that includes the ETH and Aion plugin, as well as the Core package:

Full package:
pod 'PocketSwift'

For individual installation:

pod PocketSwift/Eth

pod PocketSwift/Aion

Pod PocketSwift/Core

Usage

If you would like you know how integrate PocketSwift into your DApp, visit our developer portal that has a lot of useful tutorials and material about Pocket Network and Pocket MVP.

Contact Us

We have created a Discord server where you can meet with the Pocket team, as well as fellow App Developers, and Service Nodes. Click here to join!

Latest podspec

{
    "name": "PocketSwift",
    "version": "0.0.1",
    "summary": "Pocket-swift package with a set of plugins that allows you to connect to the Eth and Aion Networks.",
    "homepage": "https://github.com/pokt-network/pocket-swift",
    "license": {
        "type": "MIT",
        "text": "MIT LicensennCopyright (c) 2019 Pocket NetworknnPermission is hereby granted, free of charge, to any person obtaining a copynof this software and associated documentation files (the "Software"), to dealnin the Software without restriction, including without limitation the rightsnto use, copy, modify, merge, publish, distribute, sublicense, and/or sellncopies of the Software, and to permit persons to whom the Software isnfurnished to do so, subject to the following conditions:nnThe above copyright notice and this permission notice shall be included in allncopies or substantial portions of the Software.nnTHE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS ORnIMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,nFITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THEnAUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHERnLIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,nOUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THEnSOFTWARE.n"
    },
    "authors": {
        "Wilson Garcia": "[email protected]",
        "Luis C. de Leon": "[email protected]",
        "Pabel Nunez": "[email protected]"
    },
    "source": {
        "git": "https://github.com/pokt-network/pocket-swift.git",
        "tag": "0.0.1"
    },
    "source_files": "PocketSwift/**/*.{h,m,swift}",
    "exclude_files": [
        "PocketSwiftTests/**/*.{h,m,swift}",
        "Pods/*"
    ],
    "swift_versions": "5",
    "cocoapods_version": ">= 1.4.0",
    "platforms": {
        "ios": "11.0"
    },
    "subspecs": [
        {
            "name": "Core",
            "source_files": "PocketSwift/Packages/Core/**/*.{h,m,swift}",
            "dependencies": {
                "RxSwift": [
                    "~> 4.0"
                ],
                "RxBlocking": [
                    "~> 4.0"
                ],
                "SwiftKeychainWrapper": [],
                "RNCryptor": [],
                "BigInt": []
            }
        },
        {
            "name": "Eth",
            "source_files": "PocketSwift/Packages/Eth/**/*.{h,m,swift}",
            "dependencies": {
                "PocketSwift/Core": [],
                "pocket-web3swift": [
                    "~> 2.1.5"
                ],
                "CryptoSwift": [],
                "BigInt": []
            }
        },
        {
            "name": "Aion",
            "source_files": "PocketSwift/Packages/Aion/**/*.{h,m,swift}",
            "dependencies": {
                "PocketSwift/Core": [],
                "BigInt": []
            },
            "resources": "PocketSwift/Packages/Aion/Resource/resource.bundle"
        }
    ]
}

Pin It on Pinterest

Share This