Latest 1.5.0
Homepage https://github.com/kaltura/playkit-ios-ima
License AGPLv3 AGPLv3
Platforms ios 9.0
Dependencies PlayKit, XCGLogger, GoogleAds-IMA-iOS-SDK
Authors

PlayKit IMA Plugin

Example

To run an Kaltura IMA smaple use:
https://github.com/kaltura/playkit-ios-samples/tree/master/IMAPluginSample

Intro & Documantation

PlayKit IMA Plugin is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "PlayKit_IMA"

For full documantation about IMA Plugin use:
https://github.com/kaltura/DeveloperPortalDocs/blob/master/documentation/Mobile-Video-Player-SDKs/v3_iOS_Ads.md

Author

[email protected]

Requirements

  • XCode8 or newer
  • iOS 9.0+
  • CocoaPods

Installation Instructions

To run the samples and add the SDK use the instructions provided here.

License and Copyright Information

All code in this project is released under the AGPLv3 license unless a different license for a particular library is specified in the applicable library path.

Copyright © Kaltura Inc. All rights reserved.
Authors and contributors: See GitHub contributors list.

Latest podspec

{
    "name": "PlayKit_IMA",
    "version": "1.5.0",
    "authors": {
        "Kaltura": "[email protected]"
    },
    "license": {
        "type": "AGPLv3",
        "text": "AGPLv3"
    },
    "summary": "PlayKit IMA Plugin",
    "homepage": "https://github.com/kaltura/playkit-ios-ima",
    "source": {
        "git": "https://github.com/kaltura/playkit-ios-ima.git",
        "tag": "v1.5.0"
    },
    "swift_version": "5.0",
    "source_files": "**/*.swift",
    "platforms": {
        "ios": "9.0"
    },
    "xcconfig": {
        "CLANG_ALLOW_NON_MODULAR_INCLUDES_IN_FRAMEWORK_MODULES": "YES",
        "OTHER_LDFLAGS": "$(inherited) -framework "GoogleInteractiveMediaAds"",
        "FRAMEWORK_SEARCH_PATHS": "$(inherited) "${PODS_ROOT}"/**",
        "LIBRARY_SEARCH_PATHS": "$(inherited) "${PODS_ROOT}"/**"
    },
    "dependencies": {
        "PlayKit": [
            "~> 3.10.0"
        ],
        "XCGLogger": [
            "7.0.0"
        ],
        "GoogleAds-IMA-iOS-SDK": [
            "3.8.1"
        ]
    }
}

Pin It on Pinterest

Share This