Latest 0.2.0
Homepage https://github.com/sbonami/PFIncrementalStore
License MIT
Platforms ios 6.0, requires ARC
Frameworks CoreData
Authors

:warning: PFIS is no longer maintained, see Parse Local Storage :warning:

Build Status
Stories in Ready
Bitdeli Badge

An NSIncrementalStore subclass for Parse

PFIncrementalStore is an
NSIncrementalStore
subclass that uses
Parse to
automatically request resources as properties and relationships are
needed.

Incremental Store Persistence

PFIncrementalStore does not persist data directly. Instead, it
manages a persistent store coordinator
that can be configured to
communicate with any number of persistent stores of your choice.

Requirements

PFIncrementalStore requires a subscription to Parse, a valid Parse App, API
Key and Secret, and minor programming knowledge. Parse subscription and
API information can be obtained at
https://www.parse.com/

PFIncrementalStore requires Xcode 4.4 with the iOS
5.0

SDK, as well as Parse 1.2 or
higher.

Installation

CocoaPods is the recommended way to add
PFIncrementalStore to your project.

Check out the PFIncrementalStore github page for installation instructions.

References

Apple has recently updated their programming guide for
NSIncrementalStore, which is available from the Developer
Center
.
You may find this useful in debugging the behavior of
PFIncrementalStore, and its interactions with your app’s Core Data
stack.

Contributors

Disclaimer

PFIncrementalStore is not affiliated, associated, authorized,
endorsed by, or in any way officially connected with Parse.com,
Parse Inc., or any of its subsidiaries or its affiliates. The
official Parse web site is available at www.parse.com.

License

PFIncrementalStore is available under the MIT license.
See the LICENSE file for more info.

Contributing

  1. Fork repository on GitHub.
  2. Create a feature branch (should indicate intention add_feature_x or issue ##_issue_name).
  3. Make changes.
  4. Test changes (rake test:ios or rake test:osx).
  5. Ensure all tests pass.
  6. Submit pull request using GitHub.

Do not modify PFIncrementalStore.podspec, the maintainers will handle those changes.

Latest podspec

{
    "deprecated_in_favor_of": "Parse-iOS-SDK",
    "name": "PFIncrementalStore",
    "version": "0.2.0",
    "summary": "Core Data Persistence with Parse, an NSIncrementalStore subclass.",
    "homepage": "https://github.com/sbonami/PFIncrementalStore",
    "license": "MIT",
    "authors": {
        "Scott BonAmi": "[email protected]"
    },
    "platforms": {
        "ios": "6.0"
    },
    "source": {
        "git": "https://github.com/sbonami/PFIncrementalStore.git",
        "tag": "0.2.0"
    },
    "source_files": [
        "PFIncrementalStore",
        "PFIncrementalStore/**/*.{h,m}"
    ],
    "public_header_files": "PFIncrementalStore/**/*.h",
    "frameworks": "CoreData",
    "requires_arc": true,
    "ios": {
        "dependencies": {
            "Parse-iOS-SDK": []
        }
    }
}

Pin It on Pinterest

Share This