Latest 1.0
Homepage https://github.com/igormatyushkin014/Peripheral
License MIT
Platforms ios 8.0
Authors

Peripheral

The way to launch apps on iOS.

How To Get Started

  • Copy content of Source folder to your project.

or

  • Use Peripheral cocoapod

Requirements

  • iOS 8 and later
  • Xcode 7 and later

Usage

Launching apps with Peripheral is incredibly easy. Just look at this:

/*
 * Launch Skype
 */

Peripheral.Skype.launchApp()

/*
 * Launch Twitter
 */

Peripheral.Twitter.launchApp()

Supported Apps

Here is a list of currently supported apps:

  • Skype
  • Twitter

This list will be constantly expanding.

Note

If you are planning to use Peripheral on iOS 9 and later versions, don’t forget to create LSApplicationQueriesSchemes array in .plist file and put there all application URL schemes which you are going to use with Peripheral framework. Details: https://developer.apple.com/library/ios/documentation/General/Reference/InfoPlistKeyReference/Articles/LaunchServicesKeys.html#//apple_ref/doc/uid/TP40009250-SW14

License

Peripheral is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Peripheral",
    "version": "1.0",
    "summary": "The way to launch apps on iOS.",
    "description": "This framework brings a new, clear and extendable way to launch apps on iOS.",
    "homepage": "https://github.com/igormatyushkin014/Peripheral",
    "screenshots": "https://github.com/igormatyushkin014/Peripheral/raw/master/Logo/logo-1024-400.png",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Igor Matyushkin": "[email protected]"
    },
    "social_media_url": "https://twitter.com/igormatyushkin1",
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/igormatyushkin014/Peripheral.git",
        "tag": "1.0"
    },
    "source_files": [
        "Source",
        "Source/**/*"
    ]
}

Pin It on Pinterest

Share This