Latest 1.0.3
Homepage https://github.com/owlorbit/owlorbit_ios_sdk
License MIT
Platforms ios 8.0
Dependencies Alamofire, SwiftyJSON, ObjectMapper, AlamofireObjectMapper
Authors

Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Documentation on API Routes

Here is the documentation of the api routes: https://github.com/owlorbit/api

Installation

OwlorbitSDK is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'OwlorbitSDK'

Implementation

Initialize Owlorbit SDK (To get your API tokens, please create a domain and navigate to https://app.owlorbit.com/account/api):

var owlorbit:OwlorbitSDK = OwlorbitSDK(publicKey:"YOUR_PUBLIC_KEY", encryptedSession:"YOUR_ENCRYPTED_SESSION", sessionHash:"YOUR_SESSION_HASH")

Then call the API:

owlorbit.owlorbitApi.getRoomsByEmail(email: "[email protected]",resultObj: {
    (ListAllRoomsModel) in
        ...
    }, error: {
    (err) in
        ...
    }
})

Author

[email protected]

License

OwlorbitSDK is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "OwlorbitSDK",
    "version": "1.0.3",
    "summary": "This is the official SDK for Owlorbit API.",
    "description": "Official SDK for Owlorbit Api",
    "homepage": "https://github.com/owlorbit/owlorbit_ios_sdk",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Owlorbit": "[email protected]"
    },
    "source": {
        "git": "https://github.com/owlorbit/owlorbit_ios_sdk.git",
        "tag": "1.0.3"
    },
    "social_media_url": "https://twitter.com/owlorbit",
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "OwlorbitSDK/Classes/**/*",
    "swift_version": "3.0",
    "dependencies": {
        "Alamofire": [
            "~> 4.4"
        ],
        "SwiftyJSON": [
            "~> 3.1.4"
        ],
        "ObjectMapper": [
            "~> 2.0"
        ],
        "AlamofireObjectMapper": [
            "~> 4.0"
        ]
    }
}

Pin It on Pinterest

Share This