Latest 1.0.0
Homepage https://github.com/Meniny/OhCrap
License MIT
Platforms ios 8.0, osx 10.10, watchos 2.0, tvos 9.0
Frameworks Foundation
Authors

An apple crash handler.

Requirements

  • iOS 8.0+
  • macOS 10.10+
  • watchOS 2.0+
  • tvOS 9.0+
  • Xcode 8 with Swift 3

Installation

CocoaPods

pod 'OhCrap'

Usage

import OhCrap
OhCrap.isEnable = true
OhCrap.delegate = self // <OhCrapDelegate>
/// <OhCrapDelegate>
func ohCrapDidCatch(_ exception: NSException, forType type: OhCrap.CrashType) {
  // ...
}

Objective-C Version

See MXCrashHandler-in-Objective-C.

Latest podspec

{
    "name": "OhCrap",
    "version": "1.0.0",
    "summary": "An apple crash handler.",
    "description": "OhCrap is an apple crash handler.",
    "homepage": "https://github.com/Meniny/OhCrap",
    "license": "MIT",
    "authors": {
        "Meniny": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Meniny/OhCrap.git",
        "tag": "1.0.0"
    },
    "social_media_url": "http://meniny.cn/",
    "platforms": {
        "ios": "8.0",
        "osx": "10.10",
        "watchos": "2.0",
        "tvos": "9.0"
    },
    "source_files": [
        "OhCrap/Source/**/*{.swift}",
        "OhCrap/Source/**/*{.h}"
    ],
    "public_header_files": "OhCrap/Source/**/*{.h}",
    "frameworks": "Foundation",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This