Latest 3.1.5
Homepage https://github.com/nearit/iOS-SDK
License MIT
Platforms ios 9.0, requires ARC
Dependencies SwiftEventBus, YapDatabase, SwiftyJSON, JWTDecode, Alamofire
Authors ,

NearIT iOS SDK

NearIT allows to engage app users by sending context-aware targeted content.

[CocoaPods]()
[CocoaPods]()
[CocoaPods]()
Documentation Status

Recipes

NearIT allows to manage apps by defining "recipes". Those are simple rules made of 3 ingredients:

  • WHO: define the target users
  • WHAT: define what action NearIT should do
  • TRIGGER: define when the action should be triggered

How it works

NearIT web interface allows you to configure all the features quickly.
Once the settings are configured, everyone – even people without technical skills – can manage context-aware mobile content.

NearIT SDK synchronizes with servers and behaves accordingly to the settings and the recipes. Any content will be delivered at the right time, you just need to handle its presentation.

Features

  • User Segmentation
  • Beacon monitoring and ranging
  • Geofence monitoring
  • Notifications and in-app content
  • Analytics

Integration guide

For information on how to integrate all NearIT feautures in your app, visit the documentation website

Latest podspec

{
    "name": "NMSDK",
    "version": "3.1.5",
    "summary": "nearit.com iOS SDK",
    "description": "nearit.com iOS SDK, which can be extended with plugins",
    "homepage": "https://github.com/nearit/iOS-SDK",
    "license": "MIT",
    "authors": {
        "Francesco Leoni": "[email protected]",
        "Vincenzo Ferrara": "[email protected]"
    },
    "source": {
        "git": "https://github.com/nearit/iOS-SDK.git",
        "tag": "3.1.5"
    },
    "source_files": [
        "NMSDK",
        "NMSDK/**/*.{h,m,swift}"
    ],
    "platforms": {
        "ios": "9.0"
    },
    "requires_arc": true,
    "dependencies": {
        "SwiftEventBus": [
            "~> 2"
        ],
        "YapDatabase": [
            "~> 2.9"
        ],
        "SwiftyJSON": [
            "~> 3.1"
        ],
        "JWTDecode": [
            "~> 2"
        ],
        "Alamofire": [
            "~> 4"
        ]
    },
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This