Latest 1.0.2
Homepage https://github.com/ObornJung/NilSafety
License MIT
Platforms ios 7.0, requires ARC
Dependencies swizzleMethod
Frameworks Foundation, UIKit
Authors

How we made NSArray、NSMutableArray、NSDictionary、NSMutableDictionary nil safe at Glow.

Version
License
Platform

Example

[[NilSafeManager sharedInstance] setupWithOdds:odds]; ///< odds is work frequency for NilSafety

Requirements

Installation

NilSafety is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'NilSafety'

Author

Oborn Jung, [email protected]

License

NilSafety is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "NilSafety",
    "version": "1.0.2",
    "summary": "Safety cushion.",
    "description": "How we made NSArrayu3001NSMutableArrayu3001NSDictionaryu3001NSMutableDictionary nil safe at Glow..",
    "homepage": "https://github.com/ObornJung/NilSafety",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Oborn.Jung": "[email protected]"
    },
    "platforms": {
        "ios": "7.0"
    },
    "source": {
        "git": "https://github.com/ObornJung/NilSafety.git",
        "tag": "1.0.2"
    },
    "source_files": "NilSafety/**/*.{m,h}",
    "public_header_files": "NilSafety/**/*.h",
    "frameworks": [
        "Foundation",
        "UIKit"
    ],
    "requires_arc": [
        "NilSafety/ARC/**/*.m",
        "NilSafety/ARC/**/*.m"
    ],
    "dependencies": {
        "swizzleMethod": []
    }
}

Pin It on Pinterest

Share This