Latest 1.0.1
License BSD
Platforms ios 7.0, requires ARC


Since GPUImage has not been updated for a long time, many bugs have not been updated, affecting the use of our own applications, so fork the GPUImage source code to maintain updates.


CocoaPods is a dependency manager for Objective-C, which automates and simplifies the process of using 3rd-party libraries like MTGPUImage in your projects. First, add the following line to your Podfile:

pod 'MTGPUImage'

Second, install MTGPUImage into your project:

pod install

New Version Update

Version 1.0.0

Initialize the project, add GPUImage source code, CocoaPods library release.

Version 1.0.1

1、GPUImage shoot video first frame black screen problem


3、Modify the YUV to BGR caused by the color problem

Latest podspec

    "name": "MTGPUImage",
    "version": "1.0.1",
    "license": "BSD",
    "summary": "An open source iOS framework.",
    "homepage": "",
    "authors": {
        "ShengQiangLiu": "[email protected]"
    "source": {
        "git": "",
        "tag": "1.0.1"
    "ios": {
        "vendored_frameworks": "Release/MTGPUImage.framework",
        "frameworks": [
    "requires_arc": true,
    "xcconfig": {
    "platforms": {
        "ios": "7.0"

Pin It on Pinterest

Share This