Latest 0.2.0
Homepage https://github.com/muukii/ModernUpperNotificationView
License MIT
Platforms ios 8.0
Dependencies UpperNotificationController, EasyPeasy, GCDKit
Authors

CI Status
Version
License
Platform

ModernUpperNotificationView is simple notification view.
powered by UpperNotificationController

ModernUpperNotificationView
ModernUpperNotificationView
ModernUpperNotificationView
ModernUpperNotificationView

Example

let notificationController = UpperNotificationController()
notificationController.windowLevel = UIWindowLevelStatusBar

let notification = NotificationContext<ModernUpperNotificationView> {
    let view = ModernUpperNotificationView(
        text: "Failure...",
        iconImage: UIImage(named: "OvalRed")!,
        tap: {
            print("tap: failure")
    })
    return view
}

notificationController.deliver(notification: notification)

Requirements

iOS 8.0 +

Installation

ModernUpperNotificationView is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "ModernUpperNotificationView"

Author

muukii, [email protected]

License

ModernUpperNotificationView is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "ModernUpperNotificationView",
    "version": "0.2.0",
    "summary": "Simple notification view in app. Powered by UpperNotificationController",
    "homepage": "https://github.com/muukii/ModernUpperNotificationView",
    "screenshots": "https://raw.githubusercontent.com/muukii/ModernUpperNotificationView/master/sample1.png",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "muukii": "[email protected]"
    },
    "source": {
        "git": "https://github.com/muukii/ModernUpperNotificationView.git",
        "tag": "0.2.0"
    },
    "social_media_url": "https://twitter.com/muukii0803",
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "ModernUpperNotificationView/Classes/**/*",
    "dependencies": {
        "UpperNotificationController": [
            "~> 0.1.0"
        ],
        "EasyPeasy": [],
        "GCDKit": []
    }
}

Pin It on Pinterest

Share This