Latest 0.0.2
Homepage https://github.com/cemolcay/MIDIEventKit
License MIT
Platforms ios 8.0, osx 10.9, requires ARC
Frameworks Foundation, CoreMIDI
Authors

MIDI data structures for Swift. Send MIDI events in human language.

Requirements

  • Swift 4.0+
  • iOS 8.0+
  • macOS 11.0+

Install

pod 'MIDIEventKit'

Usage

Send or receive MIDIPackets or MIDIPacketLists from CoreMIDI or AudioKit‘s AKMIDI easily with MIDIEventKit data structures.

Documentation

You can find documentation on here.

App Store

This library has battle tested within my apps on App Store. Check them out!

  • ArpBud (iOS)
  • ScaleBud (iOS, AUv3)

Latest podspec

{
    "name": "MIDIEventKit",
    "version": "0.0.2",
    "swift_version": "4.2",
    "summary": "MIDI data structures for Swift. Send MIDI events in human language.",
    "description": "MIDIEventKitn===nMIDI data structures for Swift. Send MIDI events in human language.nnnRequirementsn----n* Swift 4.0+n* iOS 8.0+n* macOS 10.9+nnInstalln----n```npod 'MIDIEventKit'n```nnUsagen----nSend or receive `MIDIPacket`s or `MIDIPacketList`s from `CoreMIDI` or [AudioKit](github.com/AudioKit/AudioKit)'s `AKMIDI` easily with MIDIEventKit data structures.",
    "homepage": "https://github.com/cemolcay/MIDIEventKit",
    "license": "MIT",
    "authors": {
        "cemolcay": "[email protected]"
    },
    "platforms": {
        "ios": "8.0",
        "osx": "10.9"
    },
    "source": {
        "git": "https://github.com/cemolcay/MIDIEventKit.git",
        "tag": "0.0.2"
    },
    "source_files": "Source/MIDIEventKit.swift",
    "resources": "Source/MIDIEventKit.strings",
    "frameworks": [
        "Foundation",
        "CoreMIDI"
    ],
    "requires_arc": true
}

Pin It on Pinterest

Share This