Latest 3.3.3.1
Homepage https://github.com/poholo/MCTencentOpenAPI
License MIT
Platforms ios 8.0, requires ARC
Authors

MCTencentOpenAPI是对TencentOpenAPI的映射,使用pod依赖管理,便于开发者快速集成TencentOpenAPI的QQ登录、分享等功能。

集成方式

pod 'MCTencentOpenAPI'

老版本请使用(3.0)之前
使用 Cocoapods-depend 插件
pod depend add TencentOpenApiSDK
或者在 Podfile 文件下添加
pod 'TencentOpenApiSDK'

notes

建立仓库的本意在于LDSDKManager集成三方库比较陈旧,当想换新的库时,发现非常难,而第三方库的管理也比较佛系,基本很难追踪历史,故打算长更新此仓库,此仓库的老版本走 TencentOpenApiSDK,3.3.3版本后会逐步转移到这个仓库。

doc

文档在目录doc下

SDKDemo

Link

文档地址-官方

sdk地址-官方

Latest podspec

{
    "name": "MCTencentOpenAPI",
    "version": "3.3.3.1",
    "summary": "TencentOpenAPIu6620u5c04",
    "description": "MCTencentOpenAPIu662fu5bf9TencentOpenAPIu7684u6620u5c04uff0cu4f7fu7528podu4f9du8d56u7ba1u7406uff0cu4fbfu4e8eu5f00u53d1u8005u5febu901fu96c6u6210TencentOpenAPIu7684QQu767bu5f55u3001u5206u4eabu7b49u529fu80fdu3002",
    "license": "MIT",
    "authors": {
        "littleplayer": "[email protected]"
    },
    "homepage": "https://github.com/poholo/MCTencentOpenAPI",
    "source": {
        "git": "https://github.com/poholo/MCTencentOpenAPI.git",
        "tag": "3.3.3.1"
    },
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "vendored_frameworks": "SDK/TencentOpenAPI.framework",
    "xcconfig": {
        "VALID_ARCHS": "arm64 x86_64"
    },
    "pod_target_xcconfig": {
        "VALID_ARCHS": "arm64 x86_64"
    },
    "ios": {
        "frameworks": [
            "CoreTelephony",
            "SystemConfiguration"
        ],
        "libraries": [
            "z",
            "sqlite3.0",
            "c++",
            "iconv"
        ]
    }
}

Pin It on Pinterest

Share This