Latest 0.0.3
Homepage https://github.com/nakaji-dayo/MapLibraryWrapper
License MIT
Platforms ios 8.0, requires ARC
Frameworks Accelerate, AVFoundation, CoreData, CoreLocation, CoreText, Foundation, GLKit, ImageIO, OpenGLES, QuartzCore, SystemConfiguration, GoogleMaps
Authors

CI Status
Version
License
Platform

Usage

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Installation

MapLibraryWrapper is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "MapLibraryWrapper"

Author

nakaji-dayo, [email protected]

License

MapLibraryWrapper is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "MapLibraryWrapper",
    "version": "0.0.3",
    "summary": "Wrapper Swift library of Map libraries(e.g. MapKit, Google Maps).",
    "description": "Wrapper Swift library of Map libraries.nTo easy the change of the Map Library from later by using this library.nnit supports following libraries.n- MapKitn- Google Maps.",
    "homepage": "https://github.com/nakaji-dayo/MapLibraryWrapper",
    "license": "MIT",
    "authors": {
        "nakaji-dayo": "[email protected]"
    },
    "source": {
        "git": "https://github.com/nakaji-dayo/MapLibraryWrapper.git",
        "tag": "0.0.3"
    },
    "social_media_url": "https://twitter.com/nakaji_dayo",
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "source_files": "Pod/Classes/**/*",
    "resource_bundles": {
        "MapLibraryWrapper": [
            "Pod/Assets/*.png"
        ]
    },
    "ios": {
        "resource_bundles": {
            "MapLibraryWrapper-ios": "Resources/*.png"
        }
    },
    "public_header_files": "Pod/Classes/**/*.h",
    "frameworks": [
        "Accelerate",
        "AVFoundation",
        "CoreData",
        "CoreLocation",
        "CoreText",
        "Foundation",
        "GLKit",
        "ImageIO",
        "OpenGLES",
        "QuartzCore",
        "SystemConfiguration",
        "GoogleMaps"
    ],
    "libraries": [
        "c++",
        "icucore",
        "z"
    ],
    "vendored_frameworks": "Dependencies/GoogleMaps.framework",
    "prepare_command": "./download-googlemaps.sh"
}

Pin It on Pinterest

Share This