Latest 0.0.2
Homepage https://github.com/Alchemistxxd/Magicians
License MIT
Platforms ios 8.0, osx 10.10, tvos 9.0, watchos 2.0
Authors

CocoaPods Compatible
Platform
Gitter

Magicians is an utility extension for interface builder by configure object visually.

Extended

  • [x] UIView / NSView
  • [x] UIScrollView / NSUIScrollView
  • [x] UIViewController / NSViewController

Requirements

  • iOS 8.0+ / macOS 10.10+ / tvOS 9.0+ / watchOS 2.0+
  • Xcode 8.3+
  • Swift 3.2+

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

To integrate Magicians into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '11.0'
use_frameworks!

target '<Your Target Name>' do
    pod 'Magicians', '~> 0.0.1'
end

Then, run the following command:

$ pod install

Usage

Attributes Inspector

Just open the interface builder and switch to attributes inspector, then configure the object visually.

Magicians
Magicians

Communication

  • If you found a bug, open an issue.
  • If you have a feature request, open an issue.
  • If you want to contribute, submit a pull request.

License

Magicians is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "Magicians",
    "version": "0.0.2",
    "license": "MIT",
    "summary": "An utility extension for interface builder.",
    "homepage": "https://github.com/Alchemistxxd/Magicians",
    "authors": {
        "0xxd0": "[email protected]"
    },
    "source": {
        "git": "https://github.com/0xxd0/Magicians.git",
        "tag": "0.0.2"
    },
    "platforms": {
        "ios": "8.0",
        "osx": "10.10",
        "tvos": "9.0",
        "watchos": "2.0"
    },
    "source_files": "Source/*.swift",
    "pushed_with_swift_version": "3.2"
}

Pin It on Pinterest

Share This