Latest 0.0.1
Homepage https://github.com/longjianjiang/LJIn-AppBrowser
License MIT
Platforms ios 7.0, requires ARC
Dependencies UMengSocial
Frameworks UIKit
Authors

This a simple but useful In-App browser.

image

Requirements

  • iOS 7.0 or later
  • ARC

Usage

LJInAppBrowserController is main Class.

    LJInAppBrowserController *browser = [[LJInAppBrowserController alloc] init];
    browser.loadingProgressColor = [UIColor orangeColor];
    browser.urlStr = @"http://www.baidu.com";
    [self.navigationController pushViewController:browser animated:YES];

Install

  • Installation with CocoaPods:pod 'LJIn-AppBrowser'
  • Manual import:
    • Drag All files in the LJInAppBrowser folder to project

License

MIT license.

Latest podspec

{
    "name": "LJIn-AppBrowser",
    "version": "0.0.1",
    "summary": "one In-App browser",
    "description": "An easy tool to use as In-App Browser.",
    "homepage": "https://github.com/longjianjiang/LJIn-AppBrowser",
    "license": "MIT",
    "authors": {
        "longjianjiang": "[email protected]"
    },
    "source": {
        "git": "https://github.com/longjianjiang/LJIn-AppBrowser.git",
        "tag": "0.0.1"
    },
    "platforms": {
        "ios": "7.0"
    },
    "requires_arc": true,
    "source_files": [
        "LJInAppBrowser/Category/*.{h,m}",
        "LJInAppBrowser/NJKWebViewProgress/*.{h,m}",
        "LJInAppBrowser/**/*.{h,m}"
    ],
    "resources": "LJInAppBrowser/LJInAppBrowser.bundle",
    "dependencies": {
        "UMengSocial": [
            "~>5.0"
        ]
    },
    "frameworks": "UIKit"
}

Pin It on Pinterest

Share This