Latest 2.0.6
Homepage https://github.com/lionheart/LionheartCurrencyTextField
License Apache 2.0
Platforms ios 10.3
Dependencies LionheartExtensions
Authors

LionheartCurrencyTextField
LionheartCurrencyTextField

CI Status
Version
Platform
Swift

LionheartCurrencyTextField is a drop-in replacement for UITextField that displays currency values the way you’d expect it to. It’s based on the user’s current locale, so in the US, typing "12345.12" will output "$12,345.12".

Example

LionheartCurrencyTextField comes with a functional example project to help you get started. To run the example project, clone the repo, and run pod install from the Example directory.

LionheartCurrencyTextField

Code Sample

let textField = LionheartCurrencyTextField()

Yep, it really is that simple.

Installation

LionheartCurrencyTextField is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "LionheartCurrencyTextField"

Author

Dan Loewenherz

License

KeyboardAdjuster is available under the Apache 2.0 LICENSE. See the LICENSE file for more info.

Latest podspec

{
    "name": "LionheartCurrencyTextField",
    "version": "2.0.6",
    "summary": "A text field that formats currency values",
    "description": "LionheartCurrencyTextField is a drop-in replacement for UITextField thatndisplays currency values the way you'd expect it to. It's based on the user'sncurrent locale, so in the US, typing "12345.12" will output "$12,345.12".nnSee the GitHub project for more details.",
    "documentation_url": "https://code.lionheart.software/LionheartCurrencyTextField/",
    "homepage": "https://github.com/lionheart/LionheartCurrencyTextField",
    "license": {
        "type": "Apache 2.0",
        "file": "LICENSE"
    },
    "authors": {
        "Dan Loewenherz": "[email protected]"
    },
    "source": {
        "git": "https://github.com/lionheart/LionheartCurrencyTextField.git",
        "tag": "2.0.6"
    },
    "social_media_url": "https://twitter.com/lionheartsw",
    "platforms": {
        "ios": "10.3"
    },
    "source_files": "LionheartCurrencyTextField/Classes/**/*",
    "dependencies": {
        "LionheartExtensions": []
    },
    "swift_version": "4.0"
}

Pin It on Pinterest

Share This