Latest 2.0.0
Homepage https://github.com/Kofktu/KUITagLabel
License MIT
Platforms ios 8.0, requires ARC
Authors

Build Status
Swift
CocoaPods
Carthage compatible

alt tag

  • TagLabel support for Dynamic height
  • Support for Accessiblity

Requirements

  • iOS 8.0+
  • Xcode 9.0
  • Swift 4.0 (>= 2.0.0)
  • Swift 3.0 (>= 1.5.0)

Installation

CocoaPods

KUITagLabel is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "KUITagLabel"

Carthage

For iOS 8+ projects with Carthage

github "Kofktu/KUITagLabel"

Usage

KUITagLabel

import KUITagLabel

let config = KUITagConfig(titleColor: UIColor.magentaColor(),
                          titleFont: UIFont.boldSystemFontOfSize(15.0),
                          ...)

tagLabel.add(KUITag(title: "#테스트", config: config))
tagLabel.add(KUITag(title: "#테스트1", config: config))
tagLabel.refresh()

Authors

Taeun Kim (kofktu), [email protected]

License

KUITagLabel is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "KUITagLabel",
    "version": "2.0.0",
    "summary": "TagLabel support for Dynamic Height",
    "description": "TagLabel support for Dynamic Height for Swift",
    "homepage": "https://github.com/Kofktu/KUITagLabel",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Kofktu": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/Kofktu/KUITagLabel.git",
        "tag": "2.0.0"
    },
    "source_files": "KUITagLabel/Classes/**/*.{swift}",
    "requires_arc": true,
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This