Latest 2.0.0
Homepage https://github.com/Kofktu/KUIButtonBar
License MIT
Platforms ios 8.0, requires ARC
Authors

Swift
CocoaPods
Carthage compatible

  • Simple Component for Multi Buttons

alt tag

Requirements

  • iOS 8.0+
  • Swift 4.0

Installation

CocoaPods

KUIButtonBar is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'KUIButtonBar'

Carthage

For iOS 8+ projects with Carthage

github "Kofktu/KUIButtonBar"

Usage

KUIButtonBarConfig

public struct KUIButtonBarConfig {
    public var toggle: Bool
    public var rowCount: Int
    public var columnCount: Int  // numberOfButtons 하기전에 값 설정해놓을것
    public var numberOfButtons: Int
    public var horizontalGap: CGFloat
    public var verticalGap: CGFloat
    public var defaultSelectedIndex: Int // toggle 값이 true 인 경우에만 KUIButtonBar refresh시 기본값으로 설정됨

KUIButtonBarDelegate

protocol KUIButtonBarDelegate {
    // Required
    func render(_ buttonBar: KUIButtonBar, button: UIButton, index: Int)

    // Optional
    optional func click(_ buttonBar: KUIButtonBar, button: UIButton, index: Int)
    optional func selected(_ buttonBar: KUIButtonBar, button: UIButton, index: Int)
}

Authors

Taeun Kim (kofktu), [email protected]

License

KUIButtonBar is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "KUIButtonBar",
    "version": "2.0.0",
    "summary": "Simple Component for Multi Buttons",
    "description": "Simple Component for Multi Buttons for Swift",
    "homepage": "https://github.com/Kofktu/KUIButtonBar",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Kofktu": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/Kofktu/KUIButtonBar.git",
        "tag": "2.0.0"
    },
    "source_files": "KUIButtonBar/Classes/**/*.{swift}",
    "requires_arc": true,
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This