Latest 2.0.0
Homepage https://github.com/Kofktu/KUIAlignmentButtonBar
License MIT
Platforms ios 8.0, requires ARC
Authors

Swift
CocoaPods
Carthage compatible

  • Alignment Multiple Buttons

alt tag

Requirements

  • iOS 8.0+
  • Swift 4.0

Installation

CocoaPods

KUIButtonBar is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'KUIAlignmentButtonBar'

Carthage

For iOS 8+ projects with Carthage

github "Kofktu/KUIAlignmentButtonBar"

Usage

KUIAlignmentButtonBar

public class KUIAlignmentButtonBar {
    var numberOfButtons: Int = 1
    var buttonGap: CGFloat = 4.0
    var alignment: KUIAlignment = .left
    var insets: UIEdgeInsets = UIEdgeInsets.zero
}

KUIAlignmentButtonBarDelegate

protocol KUIAlignmentButtonBarDelegate {
    // Required
    func render(_ buttonBar: KUIAlignmentButtonBar, button: UIButton, index: Int)

    // Optional
    optional func click(_ buttonBar: KUIAlignmentButtonBar, button: UIButton, index: Int)
    optional func selected(_ buttonBar: KUIAlignmentButtonBar, button: UIButton, index: Int)
}

Authors

Taeun Kim (kofktu), [email protected]

License

KUIAlignmentButtonBar is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "KUIAlignmentButtonBar",
    "version": "2.0.0",
    "summary": "Alignment Multiple Buttons",
    "description": "Alignment Multiple Buttons for Swift",
    "homepage": "https://github.com/Kofktu/KUIAlignmentButtonBar",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Kofktu": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/Kofktu/KUIAlignmentButtonBar.git",
        "tag": "2.0.0"
    },
    "source_files": "KUIAlignmentButtonBar/Classes/**/*.{swift}",
    "requires_arc": true,
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This