Latest 0.8.0
Homepage https://github.com/Kommunicate-io/Kommunicate-iOS-SDK
License BSD-3-Clause
Platforms ios 9.0
Dependencies ApplozicSwift
Authors

header-ios

Version
License
Platform

Kommunicate iOS Chat SDK for Customer Support

An Open Source iOS Live Chat SDK for Customer Support

Overview

Kommunicate provides open source live chat SDK in iOS. The Kommunicate SDK is flexible, lightweight and easily integrable. It lets you easily add real time live chat and in-app messaging in your mobile applications and websites for customer support. The SDK is equipped with advance messaging options such as sending attachments, sharing location and rich messaging.

support-ios

Kommunicate SDK lets you integrate custom chatbots in your mobile apps for automating tasks. It comes with multiple features to make it a full fledged customer support SDK.

bot-ios

To get started with Kommunicate iOS SDK, head over to Kommunicate website and Signup to get your Application ID.


Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

  • iOS 9.0+
  • Xcode 8.2+
  • Swift 3.0+

Installation

Kommunicate is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'Kommunicate'

Then run pod install.

In any file you’d like to use Kommunicate in, don’t forget to
import the framework with import Kommunicate.

Docs

Please checkout Documentation for more details.

License

Kommunicate is available under the BSD-3-Clause license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Kommunicate",
    "version": "0.8.0",
    "summary": "Kommunicate iOS SDK for customer support.",
    "homepage": "https://github.com/Kommunicate-io/Kommunicate-iOS-SDK",
    "license": {
        "type": "BSD-3-Clause",
        "file": "LICENSE"
    },
    "authors": {
        "Mukesh Thawani": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Kommunicate-io/Kommunicate-iOS-SDK.git",
        "tag": "0.8.0"
    },
    "social_media_url": "https://twitter.com/kommunicateio",
    "platforms": {
        "ios": "9.0"
    },
    "swift_version": "4.1",
    "source_files": "Kommunicate/Classes/**/*.{swift}",
    "resources": "Kommunicate/Assets/**/*{lproj,storyboard,xib,xcassets,json}",
    "dependencies": {
        "ApplozicSwift": [
            "~> 1.0.0"
        ]
    }
}

Pin It on Pinterest

Share This