Latest 0.0.3
Homepage https://github.com/SethSky/KOLocalizedString
License MIT
Platforms ios 9.3
Authors

Build Status
CocoaPods Compatible
Platform

KOLocalizedString is an Localization library written in Swift.

Features

  • [x] Usage .plist / .strings files
  • [x] Update files from server
  • [x] Update localization without rebooting application

Requirements

  • iOS 9.0+
  • Xcode 8.3+
  • Swift 3.1+

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

CocoaPods 1.1+ is required to build KOLocalizedString 0.0.1+.

To integrate KOLocalizedString into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '10.0'
use_frameworks!

target '<Your Target Name>' do
    pod 'KOLocalizedString', '~> 0.0.3'
end

Then, run the following command:

$ pod install

License

KOLocalizedString is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "KOLocalizedString",
    "version": "0.0.3",
    "license": "MIT",
    "summary": "Alternative NSLocalizedu200bString in Swift",
    "homepage": "https://github.com/SethSky/KOLocalizedString",
    "authors": {
        "Oleksandr Khymych": "[email protected]"
    },
    "source": {
        "git": "https://github.com/SethSky/KOLocalizedString.git",
        "tag": "0.0.3"
    },
    "platforms": {
        "ios": "9.3"
    },
    "source_files": "Source/*.swift"
}

Pin It on Pinterest

Share This