Latest 2.0.0
Homepage https://github.com/hyperoslo/Keychains
License MIT
Platforms ios 9.0, osx 10.10, requires ARC
Frameworks Security
Authors

Version
Carthage Compatible
License
Platform
Swift

A keychain wrapper that is so easy to use that your cat could use it.

Usage

// Save and/or update a password
Keychain.setPassword(password, forAccount: account)

// Get a password
Keychain.password(forAccount:account)

// Delete a password
Keychain.deletePassword(forAccount: account)

Installation

Keychains is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'Keychains'

Keychain is also available through Carthage.
To install just write into your Cartfile:

github "hyperoslo/Keychains"

Author

Hyper Interaktiv AS, [email protected]

License

Keychains is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Keychains",
    "summary": "A keychain wrapper that is so easy to use that your cat could use it.",
    "version": "2.0.0",
    "homepage": "https://github.com/hyperoslo/Keychains",
    "license": "MIT",
    "authors": {
        "Hyper Interaktiv AS": "[email protected]"
    },
    "source": {
        "git": "https://github.com/hyperoslo/Keychains.git",
        "tag": "2.0.0"
    },
    "social_media_url": "https://twitter.com/hyperoslo",
    "platforms": {
        "ios": "9.0",
        "osx": "10.10"
    },
    "requires_arc": true,
    "ios": {
        "source_files": "Source/{iOS,Shared}/**/*"
    },
    "osx": {
        "source_files": "Source/{Mac,Shared}/**/*"
    },
    "frameworks": "Security",
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "4.0"
    },
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This