Latest 1.0.5
Homepage https://github.com/darrarski/KeyboardFrameChangeListener
License MIT
Platforms ios 10.0, requires ARC
Frameworks UIKit
Authors

Platform
Swift v4.2
Maintainability
Test Coverage
Build Status
CocoaPods
Carthage compatible

Notifies you when on-screen keyboard changes its frame.

Install

Minimum deployment target: iOS 10.0

CocoaPods

You can integrate KeyboardFrameChangeListener with your project using CocoaPods. Just add this line to your Podfile:

pod 'KeyboardFrameChangeListener', '~> 1.0'

Carthage

You can also use Carthage if you prefer by adding following line to your Cartfile:

github "darrarski/KeyboardFrameChangeListener" ~> 1.0

Use

Check out included DemoApp or ScrollViewController library which uses KeyboardFrameChangeListener under the hood.

TL;DR

let listener: KeyboardFrameChangeListening 
listener = KeyboardFrameChangeListener(notificationCenter: NotificationCenter.default)
listener.keyboardFrameWillChange = { change in
    print("Keybaord frame will change: (change)")
}

Develop

Requirements:

To bootstrap the project run:

bundle install
bundle exec fastlane setup

Then open KeyboardFrameChangeListener.xcodeproj in Xcode.

Use DemoApp build scheme for building and runing demo app.

Use Tests build scheme for runing tests.

To run tests from command line execute:

bundle exec fastlane test

To generate and open test coverage report in HTML format, run:

bundle exec fastlane coverage

License

MIT License – check out LICENSE file.

Latest podspec

{
    "name": "KeyboardFrameChangeListener",
    "version": "1.0.5",
    "summary": "Notifies you when on-screen keyboard changes its frame",
    "homepage": "https://github.com/darrarski/KeyboardFrameChangeListener",
    "authors": {
        "Dariusz Rybicki": "[email protected]"
    },
    "social_media_url": "https://twitter.com/darrarski",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "source": {
        "git": "https://github.com/darrarski/KeyboardFrameChangeListener.git",
        "tag": "v1.0.5"
    },
    "platforms": {
        "ios": "10.0"
    },
    "swift_version": "4.2",
    "source_files": "Sources",
    "requires_arc": true,
    "frameworks": "UIKit"
}

Pin It on Pinterest

Share This