Latest 1.0.5
Homepage https://github.com/skykywind/JFJExtension
License MIT
Platforms ios 10.0
Dependencies SnapKit
Authors

JFJExtension complements the UIKit and Foundation frameworks, simplifies system method calls and helps us develop projects faster. At the same time, some extensions will make the Swift code cleaner and beautiful.

CI Status
Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Cases

创建UIView及其子类

_ = UIView()
    .addTo(view)
    .config {
        $0.x = 100
        $0.y = 100
        $0.size = CGSize(width: 100, height: 100)
        $0.backgroundColor = UIColor.red
    }

 _ = UILabel()
     .addTo(view)
     .config {
        $0.text = "Hello JFJExtion"
        $0.font = UIFont.systemFont(ofSize: 14)
        $0.textColor = .red
     } 
     .layout {
        $0.top.equalToSuperview().offset(300)
        $0.centerX.equalToSuperview()
     }

Requirements

Installation

JFJExtension is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'JFJExtension'

Author

skykywind, [email protected]

License

JFJExtension is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "JFJExtension",
    "version": "1.0.5",
    "summary": "JFJExtension is an extension to some common classes in the UIKit and Foundation frameworks.",
    "description": "JFJExtension is an extension to some common classes in the UIKit and Foundation frameworks. I added many common functions to the system classes, so we can use it more convenience.",
    "homepage": "https://github.com/skykywind/JFJExtension",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "skykywind": "[email protected]"
    },
    "source": {
        "git": "https://github.com/skykywind/JFJExtension.git",
        "tag": "1.0.5"
    },
    "platforms": {
        "ios": "10.0"
    },
    "source_files": "JFJExtension/Classes/**/*",
    "swift_versions": [
        "4.2",
        "5.0"
    ],
    "dependencies": {
        "SnapKit": []
    }
}

Pin It on Pinterest

Share This