Latest 0.1.2
Homepage https://github.com/assisjeferson/JATableViewRowAction
License MIT
Platforms ios 8.0, requires ARC
Authors

CI Status
Version
License
Platform

A lib inspired in BGTableViewRowActionWithImage

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

  • iOS 8.0+
  • Xcode 8+
  • Swift 3

Installation

CocoaPods is a dependency manager for Cocoa projects.
JATableViewRowAction is available through CocoaPods. To install
it, simply add the following line to your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '9.0'
use_frameworks!

pod "JATableViewRowAction"

Then run the following command:

$ pod install

Usage


// In your imports:
import JATableViewRowAction

// In your code:
JATableViewRowAction.rowAction(style: UITableViewRowActionStyle,
                               title: String,
                          titleColor: UIColor,
                               image: UIImage,
                     backgroundColor: UIColor,
                               frame: CGSize,
                                font: UIFont?,
                             handler: @escaping ((UITableViewRowAction, IndexPath) -> Swift.Void)

Author

assisjeferson, [email protected]

License

JATableViewRowAction is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "JATableViewRowAction",
    "version": "0.1.2",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "summary": "A custom TableViewRowAction to use only image and image with text.",
    "homepage": "https://github.com/assisjeferson/JATableViewRowAction",
    "authors": {
        "assisjeferson": "[email protected]"
    },
    "source": {
        "git": "https://github.com/assisjeferson/JATableViewRowAction.git",
        "tag": "0.1.2"
    },
    "platforms": {
        "ios": "8.0"
    },
    "ios": {
        "frameworks": [
            "UIKit",
            "Foundation"
        ]
    },
    "source_files": "Source/**/*.swift",
    "requires_arc": true,
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This