Latest 0.0.3
Homepage https://github.com/mukeshydv/Inflect
License MIT
Platforms ios 8.0, osx 10.9, watchos 2.0, tvos 9.0, requires ARC
Authors

CI Status
Version
License
Platform
Language
codecov

Swift implementation of PERL library Lingua::EN::Inflect

Installation

Swift Package Manager

To install Inflect via SPM add following dependency in your Package.swift file.

// swift-tools-version:4.0
import PackageDescription

let package = Package(
    name: "YOUR_PROJECT_NAME",
    dependencies: [
        .package(url: "https://github.com/mukeshydv/Inflect.git", from: "0.0.3"),
    ]
)

CocoaPods

Inflect is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "Inflect"

Latest podspec

{
    "name": "Inflect",
    "version": "0.0.3",
    "summary": "Swift implementation of Inflect",
    "description": "Swift implementation of PERL library Inflect, Convert english words into their Singular or Plural Form",
    "homepage": "https://github.com/mukeshydv/Inflect",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Mukesh Yadav": "[email protected]"
    },
    "requires_arc": true,
    "platforms": {
        "ios": "8.0",
        "osx": "10.9",
        "watchos": "2.0",
        "tvos": "9.0"
    },
    "source": {
        "git": "https://github.com/mukeshydv/Inflect.git",
        "tag": "0.0.3"
    },
    "source_files": "Sources/**/*.swift"
}

Pin It on Pinterest

Share This