Latest 1.0.0
Homepage https://github.com/Meniny/IM
License MIT
Platforms ios 8.0, requires ARC
Dependencies CocoaHelper, SystemSounds
Frameworks Foundation, UIKit, QuartzCore, CoreGraphics, CoreLocation, MapKit, MobileCoreServices, AVFoundation
Authors

An iOS IM UI framework.

Requirements

  • iOS 8.0+
  • Xcode 8 with Swift 3

Installation

CocoaPods

pod 'IM'

Preview

ScreenShot.png

Latest podspec

{
    "name": "IM",
    "version": "1.0.0",
    "summary": "An iOS IM UI framework written in Swift.",
    "description": "IM is an iOS IM UI framework written in Swift.",
    "homepage": "https://github.com/Meniny/IM",
    "license": "MIT",
    "authors": {
        "Meniny": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Meniny/IM.git",
        "tag": "1.0.0"
    },
    "social_media_url": "http://meniny.cn/",
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "IM/**/*.{h,m,swift}",
    "public_header_files": "IM/**/*.{h}",
    "resources": [
        "IM/**/*.{xib}",
        "IM/**/*.{bundle}"
    ],
    "frameworks": [
        "Foundation",
        "UIKit",
        "QuartzCore",
        "CoreGraphics",
        "CoreLocation",
        "MapKit",
        "MobileCoreServices",
        "AVFoundation"
    ],
    "dependencies": {
        "CocoaHelper": [],
        "SystemSounds": []
    },
    "requires_arc": true,
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This