Latest 1.1.3
Homepage https://github.com/18plan/IFXRefresher
License MIT
Platforms ios 6.0, requires ARC
Authors

Injection for Xcode auto Refresher, accelerates iOS development. IFXRefresher help us develop iOS UI so much.
It’s a tiny library need to work together with Xcode plugin injectionforxcode. IFXRefresher auto refreshs
running app’s current viewcontroller, after we inject source from Xcode.

Requirements

Installation

pod ‘IFXRefresher’, ‘~>1.1.3’

Usage

First of all, you should install injectionforxcode Xcode plugin.

To start IFXRefresher

- (BOOL)application:(UIApplication *)application didFinishLaunchingWithOptions:(NSDictionary *)launchOptions {
    [IFXRefresher startMonitor];
    //you code
}

Run you app, now you can use "ctrl+=" to refresh you viewcontroller. This refresher is now work for all viewcontroller
without any start params. But sometime’s we need controller with start params. There are two ways to let IFXRefresher
konw which params we need for current viewcontroller.

  • Add all controller start params with prefix ‘with_’
  • Config manually
    [IFXRefresher addViewControllerName:@"viewcontroller name" withParamNames:@[@"param1", @"param2", ...]];
    //or
    [IFXRefresher addViewController:vc withParamNames:@[@"param1", @"param2", ...]];
    //or
    [IFXRefresher addViewControllerClass:vcClass withParamNames:@[@"param1", @"param2", ...]];

Latest podspec

{
    "name": "IFXRefresher",
    "version": "1.1.3",
    "license": "MIT",
    "summary": "Injection for Xcode auto Refresher, accelerates iOS development.",
    "homepage": "https://github.com/18plan/IFXRefresher",
    "authors": {
        "ShandaGames": "http://www.sdo.com"
    },
    "source": {
        "git": "https://github.com/18plan/IFXRefresher.git",
        "tag": "1.1.3"
    },
    "description": "IFXRefresher help us develop iOS UI so much. This is a tiny library need to work together nwith Xcode plugin injectionforxcode at https://github.com/johnno1962/injectionforxcode.",
    "source_files": "Source/*.{h,m}",
    "ios": {
        "frameworks": [
            "Foundation",
            "UIKit"
        ]
    },
    "platforms": {
        "ios": "6.0"
    },
    "requires_arc": true
}

Pin It on Pinterest

Share This