Latest 0.1.1
Homepage https://github.com/hujewelz/hotaru
License MIT
Platforms ios 8.0
Dependencies Alamofire
Authors

CI Status
Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Usage

It is easy to use Hotaru:

Provider<UserApi>(.users).JSONData { (response) in
    let res = response.map{ User($0["data"] as! [String : Any]) }
    guard let user = res.value else {
        return
    }

    print(user)
}

Requirements

Swift Version iOS Version
3.x >= 8.0

Installation

Hotaru is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "Hotaru"

Author

huluobobo, [email protected]

License

Hotaru is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Hotaru",
    "version": "0.1.1",
    "summary": "networking framework whit swift 3.0.",
    "homepage": "https://github.com/hujewelz/hotaru",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "hujewelz": "[email protected]"
    },
    "source": {
        "git": "https://github.com/hujewelz/hotaru.git",
        "tag": "0.1.1"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "Hotaru/Classes/**/*",
    "dependencies": {
        "Alamofire": [
            "~> 4.5.0"
        ]
    },
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This