Latest1.0.8
Homepagehttps://github.com/oper0960/GWSimpleAlert
LicenseMIT
Platformsios 8.0
Authors

Version
License
Platform

Example

Usage

Standard

GWAlert(title: "Title", message: "Message")
           .setActionConfirm(title: "OKActionTitle", complete: { action in
                // Set Confirm Action
           }).setActionCancel(title: "CancelActionTitle", complete: { action in
                // set Cancel Action
           }).show()

AddTextField

GWAlert(title: "Title", message: "Message")
            .addTextField(placeholder: "placeholder", keyboardType: .default)
            .setActionConfirm(title: "ActionTitle", complete: { action in
                // Set Confirm Action
            }, tfHandler: { text in
                // Return TextField Text
            })
            .setActionCancel(title: "ActionTItle", complete: { action in
                // set Cancel Action
            }).show()

Requirements

Xcode 8+ , Swift 3.2+

Installation

GWSimpleAlert is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'GWSimpleAlert'

Author

Gilwan Ryu, [email protected]

License

GWSimpleAlert is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "GWSimpleAlert",
    "version": "1.0.8",
    "summary": "Easy to use UIAlertController",
    "description": "Simple UIAlertController and UIAlertAction",
    "homepage": "https://github.com/oper0960/GWSimpleAlert",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Gilwan Ryu": "[email protected]"
    },
    "source": {
        "git": "https://github.com/oper0960/GWSimpleAlert.git",
        "tag": "1.0.8"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "GWSimpleAlert/Classes/**/*",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This