Latest 0.0.1
Homepage https://github.com/devfeather/GradientLoading
License MIT
Platforms ios 8.0, requires ARC
Authors

Swift
CocoaPods

  • Easy to use Loading View in iOS

image

Requirements

  • iOS 8.0+
  • Swift 3.0

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Installation

CocoaPods

GradientLoading is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'GradientLoading'

Usage

// Setup Text, Font, Stroke Color, Stroke Width.
GradientLoading.shared.setFontAttributes(text: "Jennie")

// use setCollectionColors or setColors.
GradientLoading.shared.setCollectionColors(.aurora)
// GradientLoading.shared.setColors([])

GradientLoading.shared.show()

Author

feather, [email protected]

License

GradientLoading is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "GradientLoading",
    "version": "0.0.1",
    "summary": "Easy to use Loading View in iOS",
    "description": "Easy to use Loading View in iOS, Install library into project.",
    "homepage": "https://github.com/devfeather/GradientLoading",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "feather": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/devfeather/GradientLoading.git",
        "tag": "0.0.1"
    },
    "source_files": "GradientLoading/Classes/**/*.{swift}",
    "exclude_files": "Classes/Exclude",
    "requires_arc": true,
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This