Latest 0.0.2
Homepage https://github.com/Kofktu/Gradientable
License MIT
Platforms ios 8.0, requires ARC
Authors

Swift
CocoaPods
Carthage compatible

  • Gradiention Protocol in iOS

alt tag

Requirements

  • iOS 9.0+
  • Swift 4.0

Installation

CocoaPods

Gradientable is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'Gradientable'

Carthage

For iOS 8+ projects with Carthage

github "Kofktu/Gradientable"

Usage

Gradientable

public protocol Gradientable {
    public func set(options: GradientableOptions)
    public func set(animation: GradientableAnimation)
}

GradientableOptions

  • Gradient color, location, direction
public struct GradientableOptions {
    var colors: [UIColor]?
    var locations: [NSNumber]?
    var direction: GradientableOptionsDirection?
}

GradientableAnimation

  • Gradient color change animation
public struct GradientableAnimation {
    var from: [UIColor]?
    var to: [UIColor]
    var duration: TimeInterval = 0.4
}

References

Please tell me or make pull request if you use this library in your application :)

Authors

Taeun Kim (kofktu), [email protected]

License

Gradientable is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Gradientable",
    "version": "0.0.2",
    "summary": "Easy to use Gradiention in iOS",
    "description": "Easy to use Gradiention Protocol in iOS",
    "homepage": "https://github.com/Kofktu/Gradientable",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Kofktu": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/Kofktu/Gradientable.git",
        "tag": "0.0.2"
    },
    "source_files": "Gradientable/Classes/**/*.{swift}",
    "requires_arc": true,
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This