Latest 0.0.3
Homepage https://github.com/serhii-londar/GithubAPI
License MIT
Platforms ios 9.0
Dependencies BaseAPI
Frameworks Foundation
Authors

CI Status
Version
License
Platform

Swift implementation of Github REST api v3. Library support swift 4.0. Work is in progress.

Currently supported:

TODO:

Example Usage

Authentication

Basic Authentication

This lib support Basic Authentication with login/password:

let authentication = BasicAuthentication(username: "username", password: "password")
UserAPI(authentication: authentication).getUser { (response, error) in
    if let response = response {
        print(response)
    } else {
        print(error ?? "")
    }
}

OAuth2 Token (sent in a header)

If you generate personal access token or receive access token from OAuth2, you can use it with AccessTokenAuthentication:

let authentication = AccessTokenAuthentication(access_token: "token")
UserAPI(authentication: authentication).getUser(username: "serhii-londar") { (response, error) in
    if let response = response {
        print(response)
    } else {
        print(error ?? "")
    }
}

OAuth2 Token (sent as a parameter)

If you generate personal access token or receive access token from OAuth2, you can use it in next way:

let authentication = TokenAuthentication(token: "token")
UserAPI(authentication: authentication).getAllUsers(since: "1") { (reposne, error) in
    if let response = response {
        print(response)
    } else {
        print(error ?? "")
    }
}

Issues API

Create Issue:

let issue = Issue(title: "New Issue")
IssuesAPI(authentication: AccessTokenAuthentication(access_token: "access_token")).createIssue(owner: "owner", repository: "repository", issue: issue) { (response, error) in
    if let response = response {

    } else {
        print(error ?? "")
    }
}

Update Issue:

let issue = Issue(title: "Updated Issue")
        IssuesAPI(authentication: AccessTokenAuthentication(access_token: "access_token")).updateIssue(owner: "owner", repository: "repository", number: number, issue: issue) { (response, error) in
    if let response = response {

    } else {
        print(error ?? "")
    }
}

Repositories API

Get list of all repositories of user:

RepositoriesAPI(authentication: AccessTokenAuthentication(access_token: "access_token")).repositories(user: "user", type: .all) { (response, error) in
    if let response = response {

    } else {
        print(error ?? "")
    }
}

Search API

Seart all repositories which contains qwer in name:

SearchAPI().searchRepositories(q: "qwer", page: 1, per_page: 100) { (response, error) in
    if let response = response {

    } else {
        print(error ?? "")
    }
}

Example Application

To run the example project, clone the repo, and run pod install from the Example directory first.

Example project contains example app with list of all user’s github notification.

Requirements

  • Xcode 9 or later
  • iOS 9.0 or later
  • macOS 10.12 or later
  • Ubuntu 16.04 or later
  • Swift 4.0 or later

Installation

GithubAPI is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'GithubAPI'

Author

Serhii Londar, [email protected]

License

GithubAPI is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "GithubAPI",
    "version": "0.0.3",
    "summary": "Swift implementation of Github REST api v3",
    "description": "Swift implementation of Github REST api v3. Library support swift 4.0. Work is in progress. Currently supported: Issues, Notification, Repositories, Search, and User API's.",
    "homepage": "https://github.com/serhii-londar/GithubAPI",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Serhii Londar": "[email protected]"
    },
    "source": {
        "git": "https://github.com/serhii-londar/GithubAPI.git",
        "tag": "0.0.3"
    },
    "social_media_url": "https://twitter.com/serhii_londar",
    "platforms": {
        "ios": "9.0"
    },
    "source_files": "GithubAPI/Classes/**/*",
    "frameworks": "Foundation",
    "dependencies": {
        "BaseAPI": []
    },
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This