Latest 0.1.0
Homepage https://github.com/goodow/GDLiveStreaming
License MIT
Platforms ios 8.0
Dependencies GPUImage, VideoCore
Authors

[![CI Status](http://img.shields.io/travis/Larry Tin/GDLiveStreaming.svg?style=flat)](https://travis-ci.org/Larry Tin/GDLiveStreaming)
Version
License
Platform

Features

  • Capturing and filtering live video via GPUImage
  • Focusing and Exposure on tap: GDLCameraUtil
  • Pause and resume during recording: GDLAlignVideoAudioTimestamp
    • Rotate camera between front and rear
    • Incoming call
    • Alarm
  • H264 video encoding using VideoToolbox
  • Push stream through RTMP

Example

To run the example project:

  1. Clone the repo, run git submodule update --init in the root directory.
  2. Run pod install from the Example directory and open GDLiveStreaming.xcworkspace file.

Requirements

Installation

GDLiveStreaming is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'GDLiveStreaming', :git => 'https://github.com/goodow/GDLiveStreaming.git'
pod 'VideoCore', :git => 'https://github.com/goodow/VideoCore.git'
pod 'glm', :podspec => 'https://raw.githubusercontent.com/goodow/GDLiveStreaming/master/glm.podspec'

Author

Larry Tin, [email protected]

License

GDLiveStreaming is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "GDLiveStreaming",
    "version": "0.1.0",
    "summary": "Audio/Video Capturing->Filtering->Encoding->RTMP pushing",
    "description": "Live audio and video manipulation pipeline",
    "homepage": "https://github.com/goodow/GDLiveStreaming",
    "license": "MIT",
    "authors": {
        "Larry Tin": "[email protected]"
    },
    "source": {
        "git": "https://github.com/goodow/GDLiveStreaming.git",
        "tag": "v0.1.0"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": [
        "GDLiveStreaming/Classes/**/*",
        "lib/libyuv/include/**/*.{h}"
    ],
    "xcconfig": {
        "HEADER_SEARCH_PATHS": "${PODS_ROOT}/boost"
    },
    "dependencies": {
        "GPUImage": [
            "~> 0.1"
        ],
        "VideoCore": [
            "~> 0.3"
        ]
    },
    "ios": {
        "vendored_libraries": "lib/libyuv/libyuv.a"
    }
}

Pin It on Pinterest

Share This