Latest 1.5.0
Homepage https://github.com/kumabook/FeedlyKit
License MIT
Platforms ios 9.0, osx 10.11
Dependencies SwiftyJSON, Alamofire
Frameworks Foundation
Authors

Build Status
SwiftPM compatible
Carthage compatible
Coverage Status
GitHub release

Feedly Cloud API client library with Swift

Requirements

  • iOS 9.0+ / macOS 10.11+ / tvOS 9.0+ / watchOS 2.0+
  • Xcode 8.0+
  • Swift 3.0+

If you use swift 2.x, use version 0.*

Installation

Carthage

You can use Carthage to install FeedlyKit by adding it to your Cartfile:

github "kumabook/FeedlyKit"

And run carthage update and setup your xcode project.

Cocoapods

You can also use Cocoapods to install FeedlyKit by adding it to your Podfile:

pod 'FeedlyKit', '~> 1.0'

Support API

Currently, FeedlyKit partially support feedly cloud apis.

  • [x] Categories API
  • [x] Entries API
  • [ ] Evernote API
  • [ ] Facebook API
  • [x] Feeds API
  • [x] Markers API
  • [ ] Microsoft API
  • [ ] Mixes API
  • [ ] OPML API
  • [x] Preferences API
  • [x] Profile API
  • [x] Search API
  • [x] Streams API
  • [x] Subscriptions API
  • [x] Tags API
  • [ ] Twitter API
  • [ ] URL Shortener API

Usage

  1. Setup the config values in FeedlyAPIClientConfig

    FeedlyKit.Config.target = .Sandbox   // .Sandbox or .Production
  2. Obtain an ouath access token. You can use NXOAuth2Client or other library
  3. Set the access token as CloudAPIClient.Config.accessToken.

    FeedlyKit.Config.accessToken = "..."
  4. You can use FeedlyKit.CloudAPIClient like below:

    let streamId                  = "..."
    var paginationParams          = PaginationParams()
    paginationParams.unreadOnly   = true
    paginationParams.count        = 15
    paginationParams.continuation = "..."
    let client                    = CloudAPIClient()
    client.fetchContents(streamId,
                       paginationParams: paginationParams,
                      completionHandler: { (response) -> Void in
                ....
    })

    You can also refer to a example project.

Dependencies

Here is the libraies that FeedlyKit uses. Thanks for the developers.

Latest podspec

{
    "name": "FeedlyKit",
    "version": "1.5.0",
    "summary": "Feedly Cloud API client library in Swift",
    "homepage": "https://github.com/kumabook/FeedlyKit",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Hiroki Kumamoto": "[email protected]"
    },
    "social_media_url": "http://twitter.com/kumabook",
    "platforms": {
        "ios": "9.0",
        "osx": "10.11"
    },
    "source": {
        "git": "https://github.com/kumabook/FeedlyKit.git",
        "tag": "1.5.0"
    },
    "frameworks": "Foundation",
    "source_files": "Source/*.swift",
    "exclude_files": "Spec/*",
    "dependencies": {
        "SwiftyJSON": [],
        "Alamofire": [
            "~> 4.5"
        ]
    }
}

Pin It on Pinterest

Share This