Latest 1.0.3
Homepage https://github.com/NextFaze/FazeKit
License APACHE
Platforms ios 9.0, requires ARC
Frameworks UIKit
Authors ,

CI Status
Version
License
Platform

A collection of extensions and convenience functions on Foundation, UIKit and other Cocoa Frameworks, built in Swift for iOS development. The spiritual successor to NFAllocInit.

Included are little things, like shorthand mutation of views:

view.left = 40.0

device accessors:

UIDevice.is4Inch()

and operator overloads for NSDate:

if oneDate < anotherDate {
    print("one date is earlier")
}

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

iOS 9.0

Installation

FazeKit is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "FazeKit"

License

FazeKit is available under the APACHE 2.0 license. See the LICENSE file for more info.

Latest podspec

{
    "name": "FazeKit",
    "version": "1.0.3",
    "summary": "A collection of helper functions and extensions for Swift iOS apps",
    "description": "A collection of extensions and convenience functions on Foundation, UIKit and other Cocoa Frameworks, built in Swift for iOS development",
    "homepage": "https://github.com/NextFaze/FazeKit",
    "license": {
        "type": "APACHE",
        "file": "LICENSE"
    },
    "authors": {
        "Ric Santos": "[email protected]",
        "Shane Woolcock": "[email protected]"
    },
    "source": {
        "git": "https://github.com/NextFaze/FazeKit.git",
        "tag": "1.0.3"
    },
    "social_media_url": "https://twitter.com/NextFaze",
    "platforms": {
        "ios": "9.0"
    },
    "requires_arc": true,
    "source_files": "FazeKit/Classes/*.swift",
    "frameworks": "UIKit",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This