Latest 1.1.1
Homepage https://github.com/daniel-barros/ExtendedUIKit
License MIT
Platforms ios 9.0, watchos 2.0, requires ARC
Dependencies ExtendedFoundation, ExtendedCoreGraphics
Authors

Swift
Platform
License

Protocols and extensions for the UIKit framework.

Includes both the ExtendedFoundation and ExtendedCoreGraphics frameworks (via dependencies if using CocoaPods, otherwise you have to include them yourself).

Installation

CocoaPods

Install CocoaPods with the following command:

$ gem install cocoapods

Go to your project directory and create a Podfile with:

$ pod init

Add these lines to your Podfile:

use_frameworks!

target '<Your Target Name>' do
    pod 'ExtendedUIKit'
end

Finally, run the following command:

$ pod install

Manually

Drag the whole project into your workspace, build it, and add the framework to the Embedded Binaries of your project.

Latest podspec

{
    "name": "ExtendedUIKit",
    "version": "1.1.1",
    "summary": "Extensions for the UIKit framework.",
    "homepage": "https://github.com/daniel-barros/ExtendedUIKit",
    "license": {
        "type": "MIT",
        "file": "LICENSE.md"
    },
    "authors": {
        "Daniel Barros": "[email protected]"
    },
    "source": {
        "git": "https://github.com/daniel-barros/ExtendedUIKit.git",
        "tag": "1.1.1"
    },
    "platforms": {
        "ios": "9.0",
        "watchos": "2.0"
    },
    "source_files": [
        "Sources/Support Files/**/*.{h,swift}",
        "Sources/Common/**/*.swift"
    ],
    "ios": {
        "source_files": "Sources/iOS/**/*.swift"
    },
    "watchos": {
        "source_files": "Sources/watchOS/**/*.swift"
    },
    "requires_arc": true,
    "dependencies": {
        "ExtendedFoundation": [],
        "ExtendedCoreGraphics": []
    },
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This