Latest 1.3.5
Homepage https://github.com/Ramotion/elastic-pull-to-update
License MIT
Platforms ios 8.0, requires ARC
Dependencies Refresher
Frameworks UIKit
Authors

Elastic pull to update

Swift 2.2
CocoaPods
CocoaPods

codebeat badge
Build Status

Twitter


Elastic pull animator for Refresher.

Requirements

  • iOS 8.0+
  • Swift 2.2

Installation

pod 'ElasticPullToUpdate'

Depends on

pod 'Refresher'

Usage

 // Use Refresher extension of UITableView
 tableView.addPullToRefreshWithAction({
    yourAsyncRefreshingCall(…, callback: {
        …
        tableView.stopPullToRefresh()
        …
    })
 }, withAnimator: ElasticPullToUpdate(…))

About

The project maintained by app development agency Ramotion Inc.

See our other open-source projects or hire us to design, develop, and grow your product.

Twitter URL
Twitter Follow

Latest podspec

{
    "name": "ElasticPullToUpdate",
    "version": "1.3.5",
    "summary": "Elastic pull animator for Refresher",
    "homepage": "https://github.com/Ramotion/elastic-pull-to-update",
    "license": "MIT",
    "authors": {
        "Mikhail Stepkin, Ramotion Inc.": "[email protected]"
    },
    "social_media_url": "https://twitter.com/Ramotion",
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/Ramotion/elastic-pull-to-update.git",
        "tag": "1.3.5"
    },
    "source_files": [
        "ElasticPullToUpdate",
        "ElasticPullToUpdate/**/*.{h,m,swift}"
    ],
    "public_header_files": "ElasticPullToUpdate/**/*.h",
    "frameworks": "UIKit",
    "requires_arc": true,
    "dependencies": {
        "Refresher": [
            "~> 0.5.0"
        ]
    }
}

Pin It on Pinterest

Share This