Latest 5.0.0
Homepage https://github.com/EFPrefix/EFFlukyProgressHUD
License MIT
Platforms ios 9.0
Dependencies MBProgressHUD, Fluky
Authors

CI Status
Version
License
Platform

EFFlukyProgressHUD is an ordinary custom loading hub, simply combines MBProgressHUD with Fluky.

Preview

Single Linear Box

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

  • XCode 9.0+
  • Swift 4.2+
  • iOS 9.0+
Version Needs
<5.0 Xcode 10.0+
Swift 4.2+
iOS 8.0+
5.x Xcode 10.2+
Swift 5.0+
iOS 8.0+

Installation

EFFlukyProgressHUD is available through CocoaPods. To install it, simply add the following line to your Podfile:

pod 'EFFlukyProgressHUD'

Use

This library simply combines MBProgressHUD with Fluky, fast use:

// 1.
EFFlukyProgressHUD.showAdded(to: self.view, animated: true)

Or you can custom it:

// 2.
let hub: EFFlukyProgressHUD = EFFlukyProgressHUD(flukyType: EFFlukyType.single)
self.view.addSubview(hub)
hub.show(animated: true)

For more information, you can see the document of MBProgressHUD and Fluky.

Author

EyreFree, [email protected]

License

EFFlukyProgressHUD is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "EFFlukyProgressHUD",
    "version": "5.0.0",
    "summary": "An ordinary custom loading view.",
    "description": "EFNavigationBar - An ordinary custom loading view.",
    "homepage": "https://github.com/EFPrefix/EFFlukyProgressHUD",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "EyreFree": "[email protected]"
    },
    "source": {
        "git": "https://github.com/EFPrefix/EFFlukyProgressHUD.git",
        "tag": "5.0.0"
    },
    "social_media_url": "https://twitter.com/EyreFree777",
    "swift_version": "5.0",
    "platforms": {
        "ios": "9.0"
    },
    "source_files": "EFFlukyProgressHUD/Classes/**/*",
    "resources": "EFFlukyProgressHUD/Assets/*.xcassets",
    "dependencies": {
        "MBProgressHUD": [
            "~> 1.1.0"
        ],
        "Fluky": [
            "~> 1.0.0"
        ]
    }
}

Pin It on Pinterest

Share This