Latest 1.0.1
Homepage https://github.com/ochornenko/DropdownGridMenu
License MIT
Platforms ios 9.0
Frameworks UIKit
Authors

Dropdown grid menu for iOS written in Swift. The menu can be presented from a navigation bar button item, in fullscreen or in a popover.

Requirements

  • iOS 9.0+
  • Xcode 9.0+
  • Swift 4.0+

Installation

CocoaPods

To integrate Alamofire into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '9.0'
use_frameworks!

target '<Your Target Name>' do
pod 'DropdownGridMenu', '~> 1.0.1'
end

Then, run the following command:

$ pod install

Manually

You can integrate DropdownGridMenu into your project manually. Clone this repo, drag and drop DropdownGridMenu folder onto your project.

Demo

Clone this repo, build and run the DropdownGridMenuDemo project in Xcode.

Usage

import DropdownGridMenu

Also see DropdownGridMenuDemo the demo project.

License

DropdownGridMenu is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "DropdownGridMenu",
    "version": "1.0.1",
    "summary": "Dropdown grid menu for iOS.",
    "description": "Dropdown grid menu for iOS written in Swift. The menu can be presented from a navigation bar button item, in fullscreen or in a popover.",
    "homepage": "https://github.com/ochornenko/DropdownGridMenu",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Oleg Chornenko": "[email protected]"
    },
    "source": {
        "git": "https://github.com/ochornenko/DropdownGridMenu.git",
        "tag": "1.0.1"
    },
    "social_media_url": "https://twitter.com/OlegCo",
    "platforms": {
        "ios": "9.0"
    },
    "source_files": "DropdownGridMenu/**/*",
    "frameworks": "UIKit",
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "4.0"
    },
    "pushed_with_swift_version": "4.0"
}

Pin It on Pinterest

Share This