Latest 1.2.5
Homepage https://github.com/Digipolitan/framework-swift-template
License BSD
Platforms ios 8.0, osx 10.10, watchos 2.0, tvos 9.0
Authors

Swift Version
Build Status
CocoaPods Compatible
Carthage Compatible
Swift Package Manager Compatible
Platform
Twitter

Installation

Using digipolitan-framework-swift-template-cli

gem install digipolitan-framework-swift-template-cli

And then execute the follow command

dg-fst --init

Check all available options here

Manually

First download the zip file and install bundler

[sudo] gem install bundler
bundle install

Then execute the install.rb and follow the instructions

bundle exec ruby install.rb

Features

How to deploy ?

First install deployment dependencies

bundle install && brew bundle

Run the following lane to start a new release version on git :

fastlane start_framework_release

This lane is a part of Digipolitan lanes

Check if everything is OK, after that publish the new release version on git

fastlane publish_framework_release

This lane is a part of Digipolitan lanes

After that 2 options are available :

  • If you keep Travis CI : Travis will run tests and will deploy CocoaPods and GitHub release
  • Otherwise you must run lanes yourself framework_deploy_cocoapods and framework_deploy_github part of Digipolitan lanes

Contributing

See CONTRIBUTING.md for more details!

This project adheres to the Contributor Covenant Code of Conduct.
By participating, you are expected to uphold this code. Please report
unacceptable behavior to [email protected].

License

DGFrameworkTemplate is licensed under the BSD 3-Clause license.

Latest podspec

{
    "name": "DGFrameworkTemplate",
    "version": "1.2.5",
    "summary": "Digipolitan framework swift template",
    "homepage": "https://github.com/Digipolitan/framework-swift-template",
    "license": {
        "type": "BSD",
        "file": "LICENSE"
    },
    "authors": {
        "Digipolitan": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Digipolitan/framework-swift-template.git",
        "tag": "v1.2.5"
    },
    "source_files": "Sources/**/*.{swift,h}",
    "platforms": {
        "ios": "8.0",
        "osx": "10.10",
        "watchos": "2.0",
        "tvos": "9.0"
    },
    "swift_version": "4.2"
}

Pin It on Pinterest

Share This