Latest 0.1.1
Homepage https://github.com/vkaramov/CubicSpline
License MIT
Platforms ios 8.0, osx 10.10
Frameworks Foundation
Authors

CI Status
Version
License
Platform

A simple cubic spline library written in Swift

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Xcode 9.2 or Xcode 9.3. Both Swift 3.x and 4.x are supported.

Installation

CubicSpline is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'CubicSpline'

If you’re not using CocoaPods, simply add the source files in the CubicSpline directory to your project. There are no dependencies and it works on Mac and iOS.

Author

Viacheslav Karamov

Credits

Based and relying on SAMCubicSpline by Sam Soffes. Example is based on SwiftCubicSpline by Giordano Scalzo.

License

CubicSpline is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "CubicSpline",
    "version": "0.1.1",
    "summary": "Cubic Spline in Swift",
    "description": "A simple cubic spline (https://en.wikipedia.org/wiki/Cubic_Hermite_spline) library written in Swift",
    "homepage": "https://github.com/vkaramov/CubicSpline",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "vkaramov": "vkaramov a_t yandex d|o|t ru"
    },
    "source": {
        "git": "https://github.com/vkaramov/CubicSpline.git",
        "tag": "0.1.1"
    },
    "swift_version": "3.2",
    "platforms": {
        "ios": "8.0",
        "osx": "10.10"
    },
    "source_files": "CubicSpline/Classes/**/*",
    "frameworks": "Foundation"
}

Pin It on Pinterest

Share This