Latest 0.0.2
Homepage https://github.com/asmz/CoveringIndicator
License MIT
Platforms ios 11.0
Authors

Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

  • iOS 11.0 or later
  • Swift 5 or later
  • Xcode 10.2 or later

Installation

CoveringIndicator is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'CoveringIndicator'

Usage

Firstly, import CoveringIndicator.

import CoveringIndicator

Let your UIViewController conforming with the CoveringIndicatorShowable protocol.

class ViewController: UIViewController, CoveringIndicatorShowable {
    ...
}

Show indicator covering the screen.

showCoveringIndicator()
showCoveringIndicator(alpha: 0.5) // Set background alpha color (default: 0.75)

Hide indicator covering the screen.

hideCoveringIndicator()

Author

Akira Shimizu / asmz

License

CoveringIndicator is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "CoveringIndicator",
    "version": "0.0.2",
    "summary": "A Swift protocol extension for Covering screens and showing activity indicator.",
    "homepage": "https://github.com/asmz/CoveringIndicator",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Akira Shimizu": "[email protected]"
    },
    "source": {
        "git": "https://github.com/asmz/CoveringIndicator.git",
        "tag": "0.0.2"
    },
    "social_media_url": "https://twitter.com/_asmz",
    "platforms": {
        "ios": "11.0"
    },
    "swift_version": "5.0",
    "source_files": "CoveringIndicator/Classes/**/*"
}

Pin It on Pinterest

Share This