Latest 0.1.0
Homepage https://github.com/broadwaylamb/Codable
License MIT
Platforms ios 9.0, osx 10.11, tvos 9.0, watchos 2.0
Authors

CI Status
Version

This library is a backport of the Swift 4 Codable stuff. It includes the implementations of the Codable protocol for standard types and Foundation types, and JSONEncoder and JSONDecoder classes as well.

Requirements

  • Swift 3.1
  • Xcode 8.3
  • iOS 9+
  • macOS 10.11+
  • watchOS 2+
  • tvOS 9+

Installation

Codable is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "Codable"

License

Codable is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Codable",
    "version": "0.1.0",
    "summary": "A backport of Swift 4 Codable.",
    "description": "This library is a backport of the Swift 4 `Codable` stuff. It includes the implementations of the `Codable` protocol for standard types and Foundation types, and `JSONEncoder` and `JSONDecoder` classes as well.",
    "homepage": "https://github.com/broadwaylamb/Codable",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "broadwaylamb": "[email protected]"
    },
    "source": {
        "git": "https://github.com/broadwaylamb/Codable.git",
        "tag": "0.1.0"
    },
    "social_media_url": "https://twitter.com/broadway_lamb",
    "platforms": {
        "ios": "9.0",
        "osx": "10.11",
        "tvos": "9.0",
        "watchos": "2.0"
    },
    "source_files": "Sources/*.swift",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This