Latest 1.0.5
Homepage https://github.com/balajiaugusta/CocoaTouchFramework
License None
Platforms ios 8.0, requires ARC
Authors

Sample Cocoa Touch Framework

Augusta

CocoaTouchFramework is created for testing and learning framework creation and usage usign cocoa pod.

How To Get Started

Installation

CocoaTouchFramework supports multiple methods for installing the library in a project.

Installation with CocoaPods

$ gem install cocoapods

CocoaPods 0.39.0+ is required to build CocoaTouchFramework 1.0.0+.

Podfile

To integrate CocoaTouchFramework into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'

pod 'CocoaTouchFramework'

Then, run the following command:

$ pod install

License

CocoaTouchFramework is released under the MIT license. See LICENSE for details.

Latest podspec

{
    "name": "CocoaTouchFramework",
    "version": "1.0.5",
    "summary": "cocoa touch framework",
    "description": "A sample cocoa touch framework with contains of model view controllers",
    "homepage": "https://github.com/balajiaugusta/CocoaTouchFramework",
    "license": "None",
    "authors": {
        "balajiaugusta": "[email protected]"
    },
    "source": {
        "git": "https://github.com/balajiaugusta/CocoaTouchFramework.git",
        "tag": "1.0.5"
    },
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "public_header_files": "CocoTouchFrameOne.framework/Headers/CocoTouchFrameOne.h",
    "source_files": "CocoTouchFrameOne.framework/Headers/CocoTouchFrameOne.h",
    "resources": [
        "CocoTouchFrameOne.framework/{BorderView,HomeViewController,SuccessViewController}.nib",
        "CocoTouchFrameOne.framework/Info.plist"
    ],
    "subspecs": [
        {
            "name": "Headers",
            "source_files": "CocoTouchFrameOne.framework/Headers"
        }
    ]
}

Pin It on Pinterest

Share This