Latest 1.8.8
Homepage https://github.com/5SMNOONMS5/CLSSwiftFunctionLibrary
License MIT
Platforms ios 8.0, requires ARC
Authors

Prerequisite

  • ARC
  • Xcode 4.4+, which supports literals syntax.
  • iOS 8+

How to install

  • [CocoaPods]
    Add pod 'CLSSwiftFunctionLibrary' to your podfile.

How to Use

  • Change working directory to Example folder first
    cd Example
  • Open CLSSwiftFunctionLibrary.xcworkspace then find ViewController.swift

  • Import CLSSwiftFunctionLibrary
    import CLSSwiftFunctionLibrary
  • Start using
    let appBuildNumber = CLSConstants.appBuildNumber
    let appBundle = CLSConstants.appBundle
    let appVersion = CLSConstants.appVersion
    let heightNavigationBar = CLSConstants.heightNavigationBar
    let heightToolbar = CLSConstants.heightToolbar
    let Userdefault = CLSConstants.userdefault

Latest podspec

{
    "name": "CLSSwiftFunctionLibrary",
    "version": "1.8.8",
    "summary": "Making functions and marco for future convenience using",
    "homepage": "https://github.com/5SMNOONMS5/CLSSwiftFunctionLibrary",
    "license": "MIT",
    "authors": {
        "Lee-Sheng Chen": "[email protected]"
    },
    "source": {
        "git": "https://github.com/5SMNOONMS5/CLSSwiftFunctionLibrary.git",
        "tag": "1.8.8"
    },
    "platforms": {
        "ios": "8.0"
    },
    "requires_arc": true,
    "source_files": "Pod/Classes/**/*.{h,m,swift}",
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This