Latest 1.0.0
Homepage https://github.com/clapnwhy/CLPTools
License MIT
Platforms ios 8.0
Dependencies AFNetworking, CYLTabBarController, ViewDeck
Frameworks UIKit, MapKit, Foundation, CoreGraphics, SystemConfiguration, MobileCoreServices, CFNetwork, QuartzCore
Authors

CI Status
Version
License
Platform

Example

To run the example project, clone the repo, and run pod install from the Example directory first.

Requirements

Installation

CLPTools is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "CLPTools"

Author

clapnwhy, [email protected]

License

CLPTools is available under the MIT license. See the LICENSE file for more info.


Architecture

  • CLPTools
  • CLPToolsInterface
  • CLPNav
  • CLPNavgationBar

Usage

CLPTools

头文件引用

#import <CLPTools/CLPTools.h>

CLPToolsInterface

工具类,如: CLPMd5 的使用

CLPMd5


[CLPTools CLPMd5:@"123456" Sel16or32: 16 Islower: YES];

CLPNav

自定义NavgationBar,如: initNavBackgroundColor 的使用

initNavBackgroundColor 先初始化


[CLPNav initNavBackgroundColor:[UIColor brownColor] andnavtitlecolor:[UIColor redColor]];

显示Nav,Nav根控制需要使用


[CLPNav CLPNav_Show: self];

显示Nav,Nav根控制需要使用


self.navigationItem.title = @"业主";

Latest podspec

{
    "name": "CLPTools",
    "version": "1.0.0",
    "summary": "A simple tool.",
    "description": "TODO: Add long description of the pod here.",
    "homepage": "https://github.com/clapnwhy/CLPTools",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "clapnwhy": "[email protected]"
    },
    "source": {
        "git": "https://github.com/clapnwhy/CLPTools.git",
        "tag": "1.0.0"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "CLPTools/Classes/**/*",
    "public_header_files": "CLPTools/Classes/**/*.h",
    "frameworks": [
        "UIKit",
        "MapKit",
        "Foundation",
        "CoreGraphics",
        "SystemConfiguration",
        "MobileCoreServices",
        "CFNetwork",
        "QuartzCore"
    ],
    "dependencies": {
        "AFNetworking": [
            "~> 3.2.1"
        ],
        "CYLTabBarController": [
            "~> 1.17.22"
        ],
        "ViewDeck": [
            "~> 3.1.0"
        ]
    }
}

Pin It on Pinterest

Share This