Latest 15.4.1
Homepage https://github.com/iException/BXAlipaySDK
License Custom
Platforms ios 7.0, requires ARC
Frameworks CoreMotion, CoreTelephony, SystemConfiguration, CFNetwork
Authors

Version
License
Platform

The official Alipay SDK for iOS apps to access Alipay platform. This is a mirror repository maintained by iOS developers from Baixing.

Requirements

  • Xcode 7+
  • ARC

Installation

BXAlipaySDK is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod "BXAlipaySDK"

iOS 9+

Add the following lines to your project’s info.plist file so that your app would be allowed to open Alipay.app.

<key>LSApplicationQueriesSchemes</key>
<array>
  <string>alipay</string>
  <string>alipayshare</string>
</array>

Also, add Alipay domains to your app’s whitelist.

<key>NSAppTransportSecurity</key>
<dict>
    <key>NSExceptionDomains</key>
    <dict>
        <key>alipay.com</key>
        <dict>
            <key>NSIncludesSubdomains</key>
            <true/>
            <key>NSTemporaryExceptionAllowsInsecureHTTPLoads</key>
            <true/>
            <key>NSTemporaryExceptionMinimumTLSVersion</key>
            <string>TLSv1.0</string>
            <key>NSTemporaryExceptionRequiresForwardSecrecy</key>
            <false/>
        </dict>
        <key>alipayobjects.com</key>
        <dict>
            <key>NSIncludesSubdomains</key>
            <true/>
            <key>NSTemporaryExceptionAllowsInsecureHTTPLoads</key>
            <true/>
            <key>NSTemporaryExceptionMinimumTLSVersion</key>
            <string>TLSv1.0</string>
            <key>NSTemporaryExceptionRequiresForwardSecrecy</key>
            <false/>
        </dict>
    </dict>
</dict>

Or if security is not an issue to your app, use the following lines.

<key>NSAppTransportSecurity</key>
<dict>
  <key>NSAllowsArbitraryLoads</key>
  <true/>
</dict>

Latest podspec

{
    "name": "BXAlipaySDK",
    "version": "15.4.1",
    "summary": "Alipay SDK for iOS to access Alipay platform.",
    "description": "It's a shame that Alipay doesn't have an official pod for their iOS SDK.nTherefore, we create this pod to track the official Alipay iOS SDK.",
    "homepage": "https://github.com/iException/BXAlipaySDK",
    "license": {
        "type": "Custom",
        "file": "LICENSE"
    },
    "authors": {
        "Yiming Tang": "[email protected]"
    },
    "source": {
        "git": "https://github.com/iException/BXAlipaySDK.git",
        "tag": "v15.4.1"
    },
    "social_media_url": "https://twitter.com/yiming_t",
    "platforms": {
        "ios": "7.0"
    },
    "requires_arc": true,
    "frameworks": [
        "CoreMotion",
        "CoreTelephony",
        "SystemConfiguration",
        "CFNetwork"
    ],
    "libraries": [
        "z",
        "c++"
    ],
    "resources": "AlipaySDK/AlipaySDK.bundle",
    "vendored_frameworks": "AlipaySDK/AlipaySDK.framework"
}

Pin It on Pinterest

Share This