Latest 0.7.0
Homepage https://github.com/blockchaincommons/iOS-Bitcoin
License Apache
Platforms ios 11.0
Dependencies CBitcoin, WolfCore
Authors

CI Status
Version
License
Platform

Blog Post

On January 25, 2019 I published an announcement for this framework on my blog here.

Requirements

  • The Bitcoin framework depends on the CBitcoin framework, which includes a pre-made build of libbitcoin. To properly install this, you need to first install the latest version of Git and the Git Large File Storage handler:
$ brew install git
$ brew install git-lfs
$ which git
/usr/local/bin/git
$ git --version
git version 2.20.1

Installation

Bitcoin is available through Cocoapods. To install it, add the following line to your Podfile:

pod 'Bitcoin'

Author

Wolf McNally, [email protected]

License

Bitcoin is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Bitcoin",
    "version": "0.7.0",
    "summary": "Swift bindings for libbitcoin, including Shamir Secret Sharing.",
    "homepage": "https://github.com/blockchaincommons/iOS-Bitcoin",
    "license": {
        "type": "Apache",
        "file": "LICENSE"
    },
    "authors": {
        "Wolf McNally": "[email protected]"
    },
    "source": {
        "git": "https://github.com/blockchaincommons/iOS-Bitcoin.git",
        "tag": "0.7.0"
    },
    "swift_versions": "5.0",
    "source_files": "Sources/Bitcoin/**/*",
    "platforms": {
        "ios": "11.0"
    },
    "module_name": "Bitcoin",
    "dependencies": {
        "CBitcoin": [],
        "WolfCore": []
    },
    "swift_version": "5.0"
}

Pin It on Pinterest

Share This